Diese Website ist optimiert für Firefox.   

Die Tippfarm

Excel: Rang innerhalb einer Zahlenliste (1.31)

Excel: Registerkarte Entwicklertools anzeigen (1.78)

Internet: Historische Zeitungen und Zeitschriften (1.86)

Internet: Soziale Netzwerke bewusst nutzen (1.96)

Outlook: Kontakte: "Speichern unter" vereinheitlichen (1.96)

OneNote: Effektiv mit Seitenvorlagen (1.96)

Excel: Matrix nach mehreren Kriterien durchsuchen (1.97)

Excel: Potenzieren mit Excel (1.97)

Internet: Google Suchergebnisse auf Deutsch (1.97)

Excel: Postleitzahlentabelle Österreich (1.97)

Outlook: Export von Outlook-Kontaktdaten nach Excel (1.97)

Outlook: Zusätzliche Kontaktinformationen dauerhaft anzeigen (1.97)

Windows: Schnellmenü aufrufen (1.98)

Internet: Registerkarte oder Fenster irrtümlich geschlossen? (1.98)

PowerPoint: Neue grafische Formen entwickeln (1.99)

Excel: Mehrere Leerzeilen an verschiedenen Positionen einfügen (1.99)

Outlook: Notizen, blitzschnell (1.99)

Internet: Datenbanken durchsuchen (1.99)

Windows: Namen und Symbole von Ordnern ändern (1.99)

Outlook: Firmennamen vereinheitlichen (1.99)

Office-Tools: Clip Organizer für Office 2013 (2.00)

Internet: Twitter Hashtag mit Bindestrich oder Leerzeichen (2.00)

Windows: Startmenü alphabetisch sortieren (2.00)

OneNote: Text in Notizen suchen und ersetzen (2.00)

PowerPoint: Ablaufdiagramm mit Detailfinformation (2.00)

Excel: Zu allen Zellen eines Bereichs einen fixen Faktor addieren (2.00)

Outlook: Straßenplan von Kontaktadresse zeigen (2.00)

Outlook: Mehrere Kontakte versenden (2.00)

Internet: Nachverfolgung (Tracking) verhindern (2.00)

Outlook: Verzögerte automatische Gelesen-Markierung von E-Mails (2.00)

Nr. 1323: Matrix nach mehreren Kriterien durchsuchen

Tippfarm auch auf:  XING und Twitter 

Aus Rubrik: Excel - Formeln und Funktionen

Tipp getestet unter Excel 2003, 2007, 2010, 2013.

Resi, die Leiterin des Hinterbacher Heimatmuseums listet die Besucherzahlen der einzelnen Öffnunstage penibel in einer Excel-Tabelle auf (im Beispiel in den Spalten A und B).
Sie hätte gerne eine Auswertung der Monatswerte, wobei die Monate in Zeilen und die Jahre in Spalten aufzulisten wären.
So löst sie das Problem:

  1. Sie erstellt eine Monatsreihe:
    • In die ZelleD2 schreibt sie die Zahl 1.
    • Sie nimmt das Ausfüllkästchen der Zelle D2 mit der Maus und zieht bei gedrückter -Taste bis D13 nach unten.
    • Dort lässt sie zuerst die Maustaste und dann die -Taste los.
  2. Resi erstellt eine Jahresreihe, indem Sie in die Zelle E1 die Zahl 2011 schreibt und die Jahresreihe wie in Punkt 2. beschrieben nach rechts fortsetzt.
  3. Jetzt werden die einzelnen Monatssummen erstellt:
    1. Zuerst bildet Resi in der Zelle D2 die Summe aller Besucherzellen (B2 bis B 211) und setzt den Bezug absolut, damit sie die Formel später nach rechts kopieren kann, ohne den Bezug auf die Spalte B zu verlieren.
    2. Sie tippt ein: "=SUMME(B2:B211", betätigt dann die Taste (damit ändert sich der Bezug zu "$B$2:$B$211"), gibt noch eine schließende Klammer ein und schließt mit ab.
  4. Mit einem Trick schränkt Resi die Summe auf das Jahr 2011 und den Monat 1 (Jänner) ein. Da sie den Fast & Easy - Tipp Rechnen mit Wahrheitswerten gründlich studiert hat, setzt sie Wahrheitswerte ein:
    • Um zu ermitteln, ob ein Datum zum Jahr (Zelle E1) gehört, gibt sie innerhalb der Summenfunktion ein:

      (JAHR($A2:$A211)=E$1)*

      Das Ergebnis des Wahrheitswerts ist 0, wenn FALSCH bzw. 1, wenn WAHR, womit sicher gestellt ist, dass nur Werte aus dem angegebenen Jahr summiert werden. Die Formel bis hierher lautet also:

      (MONAT($A2:$A211)=$D2)*

      Und schon haben wir die vollständige Formel:

      =SUMME((JAHR($A2:$A211)=E$1)*(MONAT($A2:$A211)=$D2)*$B$2:$B$211)

  5. Um die Bereiche in den Funktionen JAHR und MONAT interpretieren zu können, benötigt Excel eine Matrixformel. Resi schließt daher nicht mit ab, sondern mit der Tastenkombination + + . Die Formel wird von Excel in geschwungene Klammern eingefasst:

    {=SUMME((JAHR($A2:$A211)=E$1)*(MONAT($A2:$A211)=$D2)*$B$2:$B$211)}

    Vergleiche auch Tipp Matrixformeln verstehen.

Weitere Tipps zum Thema

Eingestellt: 29.11.11 - Update: 30.08.2014 - Abrufe: 17.248