Excel - Datenverwaltung und -bearbeitung - Tipp Nr. 1425

Komplexe Bedingungen für SVERWEIS

Tipp getestet unter Excel 2007, 2010, 2013, 2013;

Mit den Tipps zum SVERWEIS sind die meisten Probleme beim Abfragen von mehreren Bedingungen aus Listen zu lösen:

Ein Stück weiter führt der Tipp SVERWEIS mit zwei Bedingungen.

Auf der XING-Tippfarm wurde aber jetzt nach der Lösung für ein noch deutlich komplexeres Problem gefragt:

Diese Tabelle listet die beiden ersten Bedingungen auf. Die Spalte "Faktor" sagt, was bei Erfüllung aller drei Bedingungen zu geschehen hat. Spalte "Hilfsfaktor" zählt einfach von 1 beginnend hoch.

Das Ergebnis ermittlen Sie so:

  1. Mit der Kombination der Funktionen INDEX und VERGLEICH ermitteln Sie den "Hilfsfaktor" für die beiden ersten Bedingungen (vgl. Tipp SVERWEIS mit zwei Bedingungen).
  2. Für die dritte Bedingung reicht die WENN-Funktion.
  3. Nun ermitteln Sie mit der MIN-Funktion den kleinsten aller drei "Hilfsfaktoren".
  4. Das bisherige Ergebnis ist das Suchkriterium (Argument 1) des SVERWEISes. Die Matrix dazu besteht aus den beiden Spalten "Hilfsfaktor" und "Faktor". Ausgegeben wird die zweite Spalte dieser Matrix.
  5. Die vollständige Formel:

    =SVERWEIS(MIN(INDEX($C$2:$C$6;VERGLEICH(A10;$A$2:$A$6;4));INDEX($C$2:$C$6;VERGLEICH(B10;$B$2:$B$6;4));WENN(C10>0;5;1));$C$2:$D$6;2)

  6. Da es sich um eine Matrixformel handelt, dürfen Sie sie nicht mit nicht mit abschließen. Drücken Sie statt dessen + (gleichzeitig gedrückt halten) und dann die -Taste.

Der Ergebnisbereich kann dann etwa so aussehen, wie der Screenshot hier rechts.

Der Hauptvorteil der hier vorgestellten Methode ist, dass Sie beliebig viele Ausformungen der Bedingung verwalten kann.

Unsere Tipps zum SVERWEIS:
SVERWEIS 1, Grundlagen
SVERWEIS 2, Fortsetzung
SVERWEIS 3 für Fortgeschrittene
SVERWEIS mit zwei Bedingungen
Komplexe Bedingungen für SVERWEIS
Das Argument Bereich_Verweis im SVERWEIS