Excel - Datenverwaltung und -bearbeitung - Tipp Nr. 1844

Sortieren + Ausblenden = gefährlich

Tipp getestet unter Excel 2003, 2007, 2010, 2013;

Das Sortieren von Excel-Listenbereichen wird gefährlich, wenn die Zeilen teilweise ausgeblendet sind. Ausgeblendete Zeilen werden nämlich nicht mitsortiert! Sie bleiben "stur" an der alten Stelle stehen.

Hier ein Beispiel:

Wenn eine Spalte summiert wird, wird die korrekte Gesamtsumme (inklusive ausgeblendeter Zeilen) gebildet (im Beispiel 31).
Wollen Sie nur sichtbare Zellen addieren, hilft ab Excel 2010 die AGGREGAT-Funktion weiter. Statt

=SUMME(B2:B7)

muss es dann heißen

=AGGREGAT(9;7;B2:B7)

Die Erklärung finden Sie im Tipp Keine Fehler bei Zusammenfassungen (AGGREGAT).