Excel - Datum und Uhrzeit - Tipp Nr. 729

Wieviele Jahre sind vergangen?

Tipp getestet unter Excel 2007;

Sie rechnen mit langen Zeiträumen? Sie arbeiten auch mit Daten vor 1900? Der folgende Tipp wird Ihnen das Leben erleichtern:

Angenommen, Sie wollen wissen, wieviele volle Jahre seit einem bestimmten Datum vergangen sind. In diesem Fall müssen Sie das Datum immer im Format "tt.mm.jjjj" erfassen. Daten ab dem 1. Jänner 1900 werden von Excel dann als Zahl, ältere Daten als Text interpretiert. In unserem Beispiel steht das Datum in Zelle A1:

Diese Formel liefert immer das korrekte Ergebnis:

=WENN(ISTTEXT(A1);
JAHR(HEUTE())-RECHTS(A1;4)-WENN(DATUM(JAHR(HEUTE());TEIL(A1;4;2);LINKS(A1;2))<=HEUTE();0;1);
JAHR(HEUTE())-JAHR(A1)-WENN(DATUM(JAHR(HEUTE());MONAT(A1);TAG(A1))<=HEUTE();0;1))

Prüfen Sie's nach!